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Copyright © 2025 PAX Technology, Inc. All rights reserved. 

The Programs (which include both the software and documentation) contain proprietary information; 
they are provided under a license agreement containing restrictions on use and disclosure and are also 
protected by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, 
disassembly, or decompiling of the Programs, except to the extent required to obtain interoperability with 
other independently created software or as specified by law, is prohibited. 

This document is provided for informational purposes only. All features and specifications are subject to 
change without notice. If there are any problems in the documentation, please report them to PAX in 
writing. This document is not warranted to be error-free. Except as may be expressly permitted in the 
license agreement for these Programs, no part of these Programs may be reproduced or transmitted in 
any form or by any means, electronic or mechanical, for any purpose. 

Security Notice: No part of this publication may be copied, distributed, stored in a retrieval system, 
translated into any human or computer language, transmitted, in any form or by any means, without the 
prior written consent of PAX Technology, Inc. 

PAX is a registered trademark of PAX Technology Limited in China and/or other countries. All other 
trademarks or brand names are the properties of their respective holders. PAX, PAXBiz, PAXSTORE, 
POSDK, The PAX Portfolio Manager, and/or other PAX products referenced herein are trademarks or 
registered trademarks of PAX Technology, Inc., or its Affiliates. Other product and company names 
mentioned herein may be trademarks of their respective owners. 

The Bluetooth® word mark and logos are registered trademarks owned by Bluetooth SIG, Inc., and any use 
of such marks by PAX Technology, Inc. is under license. Other trademarks and trade names are those of 
their respective owners. 

EMV® is a registered trademark in the U.S. and other countries and an unregistered trademark elsewhere. 
The EMV trademark is owned by EMVCo, LLC. 

Android is a trademark of Google LLC. 

TECHNICAL SUPPORT 

If you encounter a problem installing, registering, or operating this product, please review the 
documentation. If you are unable to resolve the issue, please contact PAX. The level of access to this 
Service is determined by the support plan arrangements made between PAX and the Organization. Please 
consult this support plan for further information about entitlements, including the hours when telephone 
support is available. 

Monday-Friday 9:00 AM to 1:00 AM EDT 
Saturday 9:00 AM to 5:00 PM EDT 
Sunday Closed 
Hours Subject to Change 

TECHNICAL SUPPORT CONTACT INFORMATION 

Phone: (877) 859-0099 
Email: support@pax.us 
URL: www.pax.us 

mailto:support@pax.us
mailto:paxstore.support@pax.us
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1. Introduction 
An Ultra-Modern Advanced Device Management System 

Industry-leading device management features are designed to manage, control, and monitor all types of 
Android and Linux devices more efficiently. 

• Automatic terminal deployment and software loading 

• Real-time application push and parameter management 

• Remote terminal control, help desk, and messaging. 

• Real-time status of terminal hardware and applications 

• Live Geo-location of each Android payment device 

This document provides the PAXSTORE North American Group release version 9.5 information. 

1.1 Purpose 
This release will include new features, enhancements, and changes to the PAXSTORE. 

1.2 Intended Audience 
• Premium Marketplace Owners 

• Resellers 

• PAX Help Desk 

1.3 Acronyms and Terms 
 

Acronyms and 
Terms Definition 

PAXSTORE North 
American Group 

The PAXSTORE North American Group is an innovative platform that provides 
modern administrative functionalities, real-time data, statistical reporting, and 
hundreds of value-added applications to help unlock the full potential of 
Android Smart terminals and turn these into a powerful business tool to boost 
in-store sales, improve the shopping experience and increase customer loyalty. 

From now on, this document, will be referred to as PAXSTORE. 

GMS Google Mobile Services (GMS) certified devices, or more recently rebranded 
by Google as Play Protect certified devices, are Android devices that have 
undergone the 60+ hour testing and approval process with Google or a 3PL lab 
on Google's behalf. This testing, which consists of various security & 
compatibility validations, ensure the Android device under test behaves, looks, 
and feels consistent with the rest of the Android ecosystem. 

KDS Kitchen Display System 
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Acronyms and 
Terms Definition 

Paging Paging is a function of memory management where a computer will store and 
retrieve data from a device's secondary storage to the primary storage. 
Memory management is a crucial aspect of any computing device, and paging 
specifically is important to the implementation of virtual memory. 
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2. New Features 
The new features section includes new features added to the PAXSTORE in this release. 

2.1 Android Enterprise 
The PAXSTORE is a comprehensive device management platform designed to unify all your devices under 
one roof. Today, we are excited to introduce a new service called Android Enterprise, allowing you to 
seamlessly manage Android devices certified by Google Mobile Services (GMS). 

With Android Enterprise service, administrators can now easily enroll any GMS certified Android device 
into the PAXSTORE. With the ability to configure and apply device policies, install, update, uninstall 
applications, and always monitor device status with unparalleled control and integration. 

For details, please refer to the PAXSTORE team at paxstore.support@pax.us.  
 
 

 
 
 

mailto:paxstore.support@pax.us
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2.2 Terminal Management 
2.2.1 New Dashboard 

The redesign of the Dashboard on the Terminal Detail page, which brings a new enhancement for users. 

2 .2.1.1 Terminal Location Map 

The expanding of the terminal location map which makes it easier for operation and updated adjust the 
style of terminal related monitoring information. 

Select [Terminal Management] > [Terminal Serial Number] > [Basic Information]. 

New 
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Previous 

 

 

 
2 .2.1.2 Checkup Results 

A new feature for the Premium Marketplace Owners is the detection results for device hardware 
health. If the CheckUp application is installed on the terminal, the detection results will be uploaded, 
and users can select to view the details of the latest detection. 

Select [Terminal Management] > [Terminal Serial Number] > [Basic Information] > [CheckUp]. 
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After selecting the CheckUp option, a pop-up window called Hardware Checkup Result will display with 
the CheckUp Summary and CheckUp Details displayed. 

 

 

 
2.2.2 Geo-Location Configuration 

2 .2.2.1 Terminal Location Configuration 

A new feature for the Premium Marketplace Owners and Resellers is a new section called Terminal 
Location Configuration and moved geo-location related configuration items from Terminal Control to this 
new section for specialized management. 
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2 .2.2.2 New Configurations for Geo-Locations 

• Geo-Location Provider - Displays the Geo-Location provider enabled for the 
marketplace and cannot be edited. 

• Provider Locating Interval (Min) - User can set the interval to locate the terminal 
by provider. 

• Force GPS Locating - The terminal will be forced to use GPS for locating, the Geo- 
Location provider will no longer locate the terminal. 

• GPS Locating Interval (Min) - After enabling the GPS locating functionality, the 
relevant configuration will appear, in which the users can set the internal to 
locate the terminal via GPS. 

Select [Terminal Management] > [Reseller] > [Profile] > Terminal Location Configuration > [Provider 
Locating Interval (Min)]. 
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2 .2.2.3 Geo-Location Features 

New features for the Premium Marketplace Owners and Resellers are in the terminal Geo-Location map 
at the terminal-level, are the new Geo-Location features like Clear Location, Auto-Lock Terminal, Set up 
Geo-Fence Location, and Ignore Geo-Fence. These new features help users manage terminals more 
conveniently. 

Select [Terminal Management] > [Reseller] > [Terminal Serial Number] > [Basic Information] > Geo- 
Location Map > Geo-Location Feature Icons. 

 

 

 
2.2.3 New Geo-Location Features 

2 .2.3.1 Clear Location 

When selected will clear the current geographic location of the terminal. 

Select [Terminal Management] > [Reseller] > [Terminal Serial Number] > [Basic Information] > Geo- 
Location Map > Geo-Location Feature Icons > [Clear Location] >. 
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After selecting the Clear Location icon, a pop-up window called Clear Location displays, select [OK] to 
confirm the option selection. 

 

 

 
After selecting OK the updated geo-location map displays the updated terminal location as a cleared 
status. 
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2 .2.3.2 Terminal Auto-Lock 

When selected it will enable the auto-locking feature. When the terminal is outside of the Geo-Fence, it 
will trigger the automatic terminal locking feature, which will lock the terminal, and a Locked message will 
be displayed on the terminal. 

Select [Terminal Management] > [Reseller] > [Terminal Serial Number] > [Basic Information] > Geo- 
Location Map > Geo-Location Feature Icons > [Terminal Auto-Lock] >. 

 

 

 
After selecting the Terminal Auto-Lock icon, a pop-up window called Set Auto-Lock will display. 

Select [Terminal Auto-Lock Enable] > [OK] to confirm. 

 

 
Note: Occasional geo-location inaccuracies, this may lead to inadvertent locking. Therefore, please 
confirm if you want to enable auto-lock. If unintentional locking occurs, proceed to the Setting section for 
unlocking. 
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If Auto-Lock has exceeded the geo-location parameters and is activated, the terminal will display the 
message “The current terminal has been locked, please authorize the unlock”. 
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2 .2.3.3 Set up Geo-Fence Location 

A feature for the Premium Marketplace Owners and Resellers is that users can set the customized Geo- 
Fence range for a single terminal. Previously, users could only see the customized Geo-Fence on the map 
but could not edit it. 

Select [Terminal Management] > [Reseller] > [Terminal Serial Number] > [Basic Information] > Geo- 
Location Map > Geo-Location Feature Icons > [Set up Geo-Fence Location] >. 

 

 



v1.0 | 13 

 

 

 
  

PAXSTORE N.A. Release Notes v9.5  
  

  
After selecting the Set up Geo-Fence Location icon, a pop-up window will display called Set Geo-Fence. 

Select Geo-Fence Safety Radius(M) > [500] minimum > [OK]. 
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2 .2.3.4 Ignore Geo-Fence 

A feature for the Premium Marketplace Owners and Resellers is the users can setup the terminal to ignore 
the Geo-Fence, thereby solving the problem of devices being locked due to inaccurate geo-location, and 
no alarms will be triggered due to exceeding the Geo-Fence. 

Select [Terminal Management] > [Reseller] > [Terminal Serial Number] > [Basic Information] > Geo- 
Location Map > Geo-Location Feature Icons > [Ignore Geo-Fence] >. 

 

 

 
After selecting the Ignore Geo-Fence icon, a pop-up window called Set Ignore Geo-Fence will display. 

Select [enable Ignore Geo-Fence] > [OK] to save the selection. 
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2 .2.3.5 Refresh Geo-Location View 

When selected will refresh the Geo-Location map. 

Select [Terminal Management] > [Reseller] > [Terminal Serial Number] > [Basic Information] > Geo- 
Location Map > Geo-Location Feature Icons > [Refresh] >. 
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2.2.4 Terminal Level Configurations 

Some new features for the Premium Marketplace Owners and Resellers are new terminal-level 
configuration items to help users better manage individual terminals. 

2 .2.4.1 Sleep Time 

Another new feature for Premium Marketplace Owners and Resellers is new terminal-level configuration 
items to help users better manage individual terminals. The Sleep Time feature allows: Set up the sleep 
time for the terminal waits at idle until it goes to sleep. The default time is Never. 

Select [Terminal Management] > [Reseller] > [Terminal] > [Basic Setting] > [Setting] > Terminal System 
Configuration > [Sleep Time Drop Down Arrow] > [Desired Sleep Time]. 
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2 .2.4.2 Network Configuration 

Added a new section called Network Configuration, where users can configure Wi-Fi, APN, and Static IP 
settings for the terminal. These settings will be sent to the terminal. 

Select [Terminal Management] > [Reseller] > [Terminal] > [Basic Setting] > [Setting] > [Network 
Configuration Down Arrow] > [EDIT NETWORK CONFIGURATION] > Pop-up Window > Network 
Configuration > [All] or [Wi-Fi] or [APN] or [Static IP] > [OK] > 
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After selecting the All option in this example, three network options will be displayed. 

 

 

 
For Wi-Fi setup, select the Wi-Fi icon. 

Select [Wi-Fi]. 
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After selecting the Wi-Fi Configuration Permission icon, the Wi-Fi Configuration Permission pop-up 
window will display. 

Select [+ CONFIGURATION] > [SSID] > drop-down selection [Security Type] > [Password] > [Confirm 
Password] > drop-down selection [proxy type] > [OK]. 
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After selecting OK a pop-up window called Wi-Fi Configuration Permission will display a list of Wi-Fi 
configurations. Select the pencil icon to edit the profile or select the trash can to delete the profile. 

 

 

 
After selecting OK a pop-up window called WiFi Setting is displayed. This window is confirming to apply 
these Wi-Fi settings to the terminal. 

Enter [Security Characters] > [OK]. 

Note: If using MFA/2FA this will require the input of the authenticator, not the security characters.  
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2.2.5 Push AirLauncher in Terminal Detail 

A new feature for Premium Marketplace Owners is a tab called Launcher in Push Task on the Terminal 
Details page. Users can now push AirLauncher to a single terminal. 

When a terminal is replaced or copied, the current Launcher will be automatically pushed to the new 
terminal. Previously, replacing or copying a terminal did not include the Launcher, requiring a push task to 
be manually created. Now, this process is fully automated. 
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2.3 Alert 
2.3.1 Device Location Tracking 

A new feature for the Premium Marketplace Owners and Resellers is the View Device Location, which lists 
devices outside of their Geo-Location boundary. It will also show the device’s location on the Geo- 
Location map. It is required that the terminal be connected to the PAXSTORE to display device information 
and current location. 

Select [Alert] > Alert > Alert List > [Out of Geo-Fence] > [Terminal] > [View Device Location icon] >. 
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After selecting the View Device Location icon, a pop-up window called View Device Location will display. 
This will display the location of the device that is outside of the Geo-Location fence. 

Select [Close] to exit. 
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2.4 Push Template 
2.4.1 Parameter Comparison Reports 

A new feature for the Premium Marketplace Owners and Resellers is the export of comparison results for 
parameter templates. 

Select [Templates] > [Push Template] > General App > [Application] > 2 x [Template] > [Template] > 
[Export Icon]. 
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After downloading the export file, locate and open the file to view the results. Please see the example 
below. 

Columns: PID, Parameter Name, Parameter Value 
 

 

 
2.4.2 Last Used Time Column 

A new feature for the Premium Marketplace Owners and Resellers is a new column called Last Used Time 
in the push template. Because it is a newly added field, the last usage time of the Push Template will be 
recorded only after release. Previous records will show as empty. Additionally, exporting the push 
template list is also supported. 

Select [Push Template] > General App > [Application] > [Template]. 
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Additionally, exporting the push template list is also supported. 

 

 



v1.0 | 27 

 

 

 
  

PAXSTORE N.A. Release Notes v9.5  
  

 
2.5 General Setting 
2.5.1 Locked Screen Settings 

A new feature for the Premium Marketplace Owners and Resellers is configuring the terminal locked 
screen. Users can configure the locked terminal’s logo and displayed message remarks. 

Note: Currently, this feature applies only to the A920 devices with firmware version 2.5.40 or greater. 
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2 .5.1.1 Locked Screen Logo 

When the terminal is locked, an image can be displayed on the terminal screen. Recommended size: 
400px X 400px. Maximum image size is 500px X 500px, maximum file size 500KB. Supported file types of 
PNG, BMP, and JPG. 

Select [General Setting] > [UI Setting] > [Advanced Setting] > [Locked Screen Setting] > [Locked Screen 
Logo] > [SAVE]. 
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2 .5.1.2 Locked Screen Message 

When the terminal is locked, a text message can be displayed on the terminal screen. The maximum 
character length is 100. 

Select [General Setting] > [UI Setting] > [Advanced Setting] > [Locked Screen Remarks] > [Locked Screen 
Message] > [SAVE]. 
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2.5.2 Product Subtype and OS 

A new feature for the Premium Marketplace Owners and Resellers, a column called Product Subtype, has 
been added to the Model Management feature. The OS column has been removed from Model 
Management. 

Select [General Management] > [Model Management] > Product Subtype. 
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2.6 User Management 
2.6.1 User Related Merchant Information 

A new feature for the Premium Marketplace Owners and Resellers is the User’s related merchant 
information displayed in the User Detail pop-up window. 

Select [User Management] > [Merchant Management] > [User] > User Detail > Merchant. 
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2.7 Audit Log 
2.7.1 Geo-Location Operation 

A new feature for the Premium Marketplace Owners is the Geo-Location Operation search option in 
Terminal type audit log. It includes user geo-location-related operations, such as auto-locking the device, 
ignoring Geo-Fence, setting radius and center points, and configuring customized Geo-Fence. 

Select [Audit Log] > [Operation Log] > [Filter Icon] > Type [Terminal] > [Geo-Location Operation] > 
[SEARCH]. 
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Example 
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2.7.2 Remarks Column 

A new feature for the Premium Marketplace Owners and Resellers is a column called Remark added to the 
exported operation logs. These are related to the Terminal and Rush RKI types, with its value being the 
terminal serial number. 

Select [Audit Log] > [Operation Log] > [Filter Icon] > Type [Operation Control] > [Enable] > [Search] > 
[Export Icon] > [Open File] > see Remark column. 

 

 

 
2.8 Store Client 
2.8.1 Terminal Serial Number Displayed 

A new feature for the Premium Marketplace Owners and Resellers is the terminal displays the terminal 
Serial No. in the Terminal Initialization page. It is the device's own serial number and cannot be edited. 
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2.9 Landing Page 
2.9.1 French 

A new feature for the Premium Marketplace Owners and Resellers French is now included in the language 
options. 

 

 



v1.0 | 36 

 

 

 
  

PAXSTORE N.A. Release Notes v9.5  
  

 
2.10 Links 
2.10.1 External Link Warning 

A new enhancement for the Premuim Marketplace Owners and Resellers is a warning  
prompt for a redirected external link. When users select an external link within the platform to navigate to 
the third-party systems, a risk warning box will pop up to inform users of relevant risks. 
 

 
2.11 Miscellaneous 
2.11.1 KDS Online Activation 

A new feature for the Premium Marketplace Owners and Resellers supports online activation 
functionality for Kitchen Display System (KDS) devices. 

2.11.2 RKI Return Error for Display Attribute Property 

A new feature for the Premium Marketplace Owners and Resellers is if the RKI push fails, your RKI push 
will be refunded.  

Note: This feature will be implemented by the end of November. 
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3. Enhancements 
3.1 Terminal Geo-Location 
3.1.1 Active Terminal Search 

A new enhancement for the Premium Marketplace Owners and Resellers is only displaying active 
terminals on the map in Terminal Geo-Location. Now only active terminals can be searched and displayed. 
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3.2 Subscription List 
3.2.1 Subscribed Email Notice 

A new enhancement for the Premium Marketplace Owners when the Subscribed firmware in the 
Subscription List is taken offline, a notification email will be sent to the marketplace administrator. 
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Firmware Offline Notification 
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3.3 Terminal Management 
3.3.1 Terminal Details Collapsed 

A new enhancement for the Premium Marketplace Owners and Resellers is the collapsed terminal 
information in Terminal Details module. After selecting the VIEW DETAIL link, the detailed information will 
be displayed on the right side of the page. 

Select [Terminal Management] > [Reseller] > [Terminal] > [Basic Information] > [VIEW DETAIL >>]. 
 

 



v1.0 | 41 

 

 

 
  

PAXSTORE N.A. Release Notes v9.5  
  

  
After selecting VIEW DETAIL, the Terminal Details section will slide over and display the details. 

Select [X] to exit the Terminal Details. 

 



v1.0 | 42 

 

 

 
  

PAXSTORE N.A. Release Notes v9.5  
  

 
3.3.2 Terminal TID Initialization 

A new enhancement for the Premium Marketplace Owners and Resellers is the terminal TID matching 
logic. 

3 .3.2.1 Enters Terminal Serial Number 

If the user enters the serial number when creating a terminal on the PAXSTORE, the terminal's serial 
number will be compared with the serial number entered. Initialization is successful only if the serial 
numbers match, otherwise, it fails. 

3 .3.2.2 Does Not Enter the Terminal Serial Number 

If the user does not enter the serial number when creating a terminal on the PAXSTORE, the logic of 
initialization remains the same as before. 
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3.3.3 Hardware List 

A new enhancement for Premium Marketplace Owners and Resellers is the Hardware List will always 
show on the Terminal Setting page. 
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3.4 Group Management 
3.4.1 Partial Push 

A new enhancement for the Premium Marketplace Owners and Resellers, users can disable the partial 
push feature anytime. 

Select [Group Management] > [Group Type] > [Group Name] > [Push Task] > [+ APP] > [App] > 
[Application] > [OK] > [Partial Push Disable]. 
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Previously, they could only modify the number of terminals to be pushed, and to push to all terminals, 
they had to make the number large enough. 

 

 

 
 
A new feature for the Premium Marketplace Owners and Resellers, users can set the number of quantity to complete 
a push task. 
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3.5 Report Center 
3.5.1 Extended Login Activity Period to 30 Days 

A new enhancement for the Premium Marketplace Owners and extended the query period from 7 days to 
30 days for the Login Activity Report. 
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3.6 Audit Log 
3.6.1 Service Setting 

A new enhancement for the Premium Marketplace Owners renamed the audit log type Service Operation 
to Service Setting, and the operation logs in the Service Center are classified here. 

Select [Audit Log] > [Operation Log] > Type [Service Setting]. 
 
 

 
3.7 API 
3.7.1 API Call Signature for Third-Party Systems 

A new enhancement for the Premium Marketplace Owners the API call signature method for third-party 
systems, changed from HmacMD5 to HmacSHA256. 

 
API Expected Behavior: The PAXSTORE server returns a boarding error when trying to set parameters with 
the display property being set to false, regardless of whether you use the push app API or parameter 
variables.   
 
API Change Update: MP Owners cannot change the hidden application parameters. API fixes, currently you 
can change the hidden parameters, but it is not effective, the fix is the API call will return an error. This is 
the correct behavior to warn the caller.
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Customer Support 
For questions or help with the PAXSTORE please contact your service provider or PAX customer support. 

 
Monday-Friday 9:00 AM to 1:00 AM EDT 
Saturday 9:00 AM to 5:00 PM EDT 
Sunday Closed 
Hours Subject to Change 

Contact Information 
support@pax.us 
(877) 859-0099 
www.pax.us 

 
PAX Technology Inc. 
8775 Baypine Road 
Jacksonville, FL 32256 

 
This document is provided for informational purposes only. All features and specifications are subject to 
change without notice. The PAX name and PAX logo are registered trademarks of PAX Corporation and/or 
its affiliates. Other names may be trademarks of their respective owners. Copyright© 2024, PAX 
Technology Limited, all rights reserved. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

*PAX Technology, Inc. is not responsible for the content, quality, accuracy, or completeness of any 
information or materials contained in on these pages. PAX Technology, Inc. does not endorse any 
content, viewpoints, products, or services contained on these pages and shall not be held liable for any 
losses caused by reliance on the accuracy, reliability, or timeliness of such information. Any person or 
entity that relies on any information obtained from these pages does so at his/her own risk. 

mailto:support@pax.us
http://www.pax.us/
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